Tello Talent, aka Robomaster TT, LED Control with DroneBlocks

We are excited to announce that you can now code your Tello Talent with DroneBlocks. This allows for cool things to be done with Tello Talent’s new LED board, based off the ESP32 microcontroller. DroneBlocks has LED coding blocks for you to pulse the LED, draw animations, and scroll text. Drone coding is now even better with flight and LED control. Watch how block programming can be used to control Robomaster TT’s LEDs here:

You can learn more about this new feature in our blog post:

Or just download/update your DroneBlocks app and give LED block coding a try with your Tello Talent!

Does the new blocks for the Tello talent include the swarm flying, and also the QR code recognition concepts. If not will one be forthcoming. Thank you.

It doesn’t currently, but we are getting started on a course that allows this to be done via Python. If that’s some of the interest to you please let me know. We’d be happy to give you early access in hopes to get your feedback. Thanks.

I ran the following Tello-Talent LED program. Takeoff occurs, but it hangs at the first LED instruction “set color”.

FYI Code was executed on a Chromebook.

We’ll give this a test tomorrow. Just to confirm it looks like you’re running the Chrome App and not the Android App for DroneBlocks. I’m fairly certain by the screenshot, but want to be 100% sure. Thanks for reporting this and I’ll share what we find.

I wonder if you’re up against environmental factors. We don’t believe it has anything to do with the LED. Just ran a test that you can see here:

Unfortunately I was not able to film Tello Talent while the mission was executing, but you can see the blocks highlighting. Also, I realize the mission is a bit different than yours, but I couldn’t see all of your blocks.

This test was run on Windows and I’ll give Chrome a try later today.

Hi Dennis,
I ran out of time today to test again. Video is very helpful.
I was not aware that Droneblocks was available on a Windows machine. Is that available for my use?

Thanks,
Mike

You bet. It’s available for any system with a Chrome Browser (Windows, Mac, Linux):


This LED Tello Talent program rarely executes to completion. It hangs at random code locations. I suspect the issue involves the use of the Shine function. Program executed on a Chromebook.

Any chance you can copy the mission link and share it here? I’ll give this a run tomorrow and report how it goes. Looks like a cool mission!

DroneBlocksByNbpxwaCaSkrSurG9JoFOhUNrI3

SnakeLED

Mike, this is such a cool mission. I ran it no problems first try. This makes me wonder if there are potential issues with your flying environment. Your code is spot on and I love the way Tello Talent flies back to its takeoff location. I’m always amazed (when there’s a good floor and lighting) how accurate Tello’s sensors are.

Keep in mind that I did reduce some of the flight distances due to the size of my garage. Oh yeah, I also removed the fly up block just because I didn’t want Tello Talent flying too high in my garage. I wonder if that has an impact. Try removing that block just to see if you get different results.

Our school’s WIFI access points were upgraded over the summer. On Thursday morning, new access point software was upgraded to remedy a very slow WIFI speed with our Window’s laptops. My students had no issues with Droneblocks program execution in both the Thursday and Friday classes. My students were using a Chromebook to connect with the TT. So yes, your point that the issue was environmental is correct. Do you have any details on the WIFI card or circuit board used by TT drone?
Thanks