DroneBlocks & Spark connection error

Hi all,
Have been using Tello Blocks for a while…decided to try to connect to my class’ DJI Spark with Drone Blocks. Got this error pictured below. Does anyone have an idea what the problem is? I have no reference sheet for the error code either.

We have seen this error before and let me take my best guess at the moment. Generally when DroneBlocks opens it needs to register the SDK with DJI’s servers so that we can control the aircraft. Is there a chance you were disconnected when you launched DroneBlocks? I would suggest closing DroneBlocks and opening it with a good connection so the app can register. Then connect to Spark. Let us know if that helps or not and we can take it from there. Also, here is quick overview:

I tried again this morning to run my Drone Blocks program on Spark.
1.Turned on Spark and Controller and they connected.
2.Connected via wifi network broadcasted by spark.
3.Opened DJI Go app to see if all firmware was current.
4.Closed DJI Go app and opened DroneBlocks app with code to takeoff, yaw rt 90, then land.
5.I previewed the mission and launched.
Result: The drone took off and hovered at 6 feet. It did nothing else. I had to manually land it myself.
Observations: Minimal sats (4), but was inside. The surface features didn’t load in the map.
I am not logged into DroneBlocks, but that hasn’t stopped the the code from working in the past with the Tello. I cannot tell what he does in the movie to “activate” the drone. I thought this was already done. The camera box only appears when the mission is launched and takes off.
Hope this helps!
My student was trying to connect this morning in class and got the following Error Code. I am attaching a picture of it.

Thanks so much for the feedback. One thing I need to point out is there isn’t currently a way for Spark to fly autonomously indoors due to the fact that we currently rely on GPS for positioning. I believe we need at least 12 satellites for this to work. Shouldn’t be a problem outdoors.

Thanks. Perhaps this is the root of my issues. We will try it outdoors and report back to you. :slightly_smiling_face:

I just wanted to get back with you…we flew the Spark this morning and the coding worked as it should with DroneBlocks. Apparently the lack of GPS inside was the issue. However, I did notice that what was supposed to be a straight line flight path was more of a slight curve. This was surprising given that it is supposed to be using satellites for positioning.
Also, the satellite imagery wasn’t loading on the screen. Is there some other issue that I’m overlooking?