Can't download new datasets from DataBot in server mode

We ran a test with a Databot getting sets with an interval of 8 seconds for 2 hours, after the test was over we couldn’t download the CSV of results, it keeps stopping near the 60% of the download.

It has been tried resetting the connection from the computer, and also using other browsers, the download is always stopped.

New tests with less datasets can’t be downloaded from the Web Panel since this happened.

We’d like to ask if it’s out of the Databot limits, and also how to reset the Databot wifi or the full Databot factory reset (if that would be a solution), and if there is a workaround to continue the download.

Hi Ariel, sorry to hear you are having this problem.

  1. I have forwarded the details to our software engineer who will be looking at it this weekend.

  2. Can you share the data set you were collecting and we’ll do some testing.

  3. In the meantime, if you don’t mind losing the dataset, try reinstalling your firmware, that should give you a clean factory reset. You can do that through a web interface here - use a windows machine!
    Update databot™ Firmware! - databot™


Hi Robert,

We don’t have files because we couldn’t download the data set.

The Databot was configured to get all the sensors as shown in the next capture.


Having the sample rate of 8,000 ms (8 seconds), and being unable to complete the downloads after the 2 hours test.


Thank you in advance for your help

Hi Ariel, if you haven’t flashed the new firmware, can you check the firmware version on your databot? Our engineer is looking at this now and testing.

You can check the firmware version using System Tools. Page 4 of the manual here, see attached snapshot for a shortcut to the instructions.

Hi Robert,

Unfortunately, we didn’t get the version of the firmware before the upgrade.

It worked again, being able to download the tests after the new firmware was installed following the instructions in the page.


Hi Ariel, we’ve done more testing and determined a few things:

  1. At 30 minutes, the experiment you were running worked fine, reconnected to the webserver and downloaded a 45K data file.

  2. At a bit over 3 hours, unable to reconnect to the webserver. It seems to kill it somehow. However, turning it off and back on in server mode, was able to connect and download the file. It was still available. NOTE: If you begin a new recording it erases the old one. 336kb file size

  3. Ran a 9.7 hour test. 4365 records. 691kb file size. Over 65,000 data points. Web server not working so had to stop and restart but again downloaded fine.

We are looking into why it is killing the webserver, but for now, it should work for you if you just turn it off and back on as described. Let me know how we can help further and I’ll post more once I have more information on the webserver.

1 Like