Connecting Tello Drone to Python

Hi @mwkappas

When you enter the python console it will tell you what version of python you are running as I have highlighted below.

If you are just in your terminal, outside the python console you can type:

python --version


python3 --version

depending upon your operating system, to get the current python version.

I hope that helps


yes it did - I just switched to the Anacondo command prompt and typed in python --version.

Here is an image of my command prompt (when I tried to create a python virtual environment):

I don’t know why I got the below response from the command propmtp when I typed “source venv/bin/activate”…

…instead of the following response (which lesson 1 indicates is the correct response…

And on another subject: I don’t know why the command “ls” does not work in my command prompt:

For your information here is the result when I type “dir”:

the following commands are also not recognized by my command prompt: “nano” &“unzip”.

(although I did extract the tell-adv-setup-master file in my File Explorer after I downloaded this zip file)

I am not sure why my file is not showing up in my command prompt - because I do see it in my File Explorer (1KB).
And here is the result when I type “pip install -r requirements.txt”:

It looks like you still need to cd one more level down from where you currently are. From the directory you’re in (previous image) you’ll need to do the following:

cd tello-adv-setup-master

and then you can run:

pip install -r requirements.txt

Well, I am no sure why I have to ‘cd’ to ‘tello-adv-setup-master’ when I am already there…but I did so…and it worked (see images below)!

I am still confused as to why some commands, like “ls”, ‘source,’ ‘nano’, ‘pwd’ do not work in the Anaconda command prompt (nor in Windows powershell - although ‘ls’ does work in Windows powershell). See image below.
Am I in my virtual environment (venv)? I am still researching these issues…

In regards to your previous message, I now understand why I had to ‘cd’ one level down (because there was another branch in the directory). Anyways, my other questions (above) still vex me. And here is another question (along with accompanying image): if I am using a Windows environment instead of a Macintosh environment, should i use .\venv\scripts\activate instead of source venv/bin/activate ?

The command ‘source’ is not working in my Windows Powershell. Also, how exactly would I use .\venv\scripts\activate?

Well, i found the answer to one of my questions (go to current working director - project file):

…but I am not sure why both (venv) and (base) and indicated - shouldn’t it be one or the other?

…and here is an update on my pip install:

More updates:

My last question for today: why is my “import cv2.aruco” not successful? (see below)
even when i try “pip install opencv-python” - still not successful…

Aruco markers for OpenCV are in a different package. You can do:

pip install opencv-contrib-python

More details here:

Good luck!

Thank you.

Here is another question: can you explain what it means that I get a different response when i type ‘python’ vs ‘python3’ in the example below?

My guess is that on some operating systems, like MacOS and Linux there are 2 executables:

python - which is typically the old Python 2.x


python3 - which is the newest Python 3.x

On windows, it might just be that you only have python and not python3.

I need some help troubleshooting connecting my computer to the Tello drone. I have been following along with the DroneBlocks Python and Tello curriculum. I have been following the GitHub links as well as the videos. I have downloaded Anaconda, Jupyter, and Packet Sender. I can connect to the Tello wifi network from the drone. I change it to my IP address and port 8889 but it doesn’t run the code. I also used the Tello IP address with port 8889 in Packet Sender to test send and I am not getting a response back from my Tello. It is still on and I am still connected to the Tello network at this time. What am I missing?

Would you mind posting a screenshot of your packet sender configuration as well as the command to communicate with Tello? This would be incredibly useful to help us debug.

Continuing the discussion from Connecting Tello Drone to Python:

Sorry for my delay in responding. I tried again on a different machine and I’m still not able to connect. Here is a screenshot - I am connected to the Tello wifi and I wait about 30 seconds before trying to send it. I also restarted the Tello and tried and it still said it could not connect. I also try again after over a minute of waiting after connecting to the Tello network.

I am not sure if I have the answer (as I am not the instructor). However, did you try going into the Settings and clicking ‘Enable UDP Servers’ and typing in a number other than 8889, such as 9000 or 9003? (see image below)

This guidance comes from the following video:

Thanks for responding! I tried 9000 and it still could not connect.