Problem with the lesson Connecting to Tello, in the OpenCV

hi everyone, I have a problem with the lesson Connecting to Tello, in the OpenCV, Python, and DroneBlocks for Tello Camera Control, I was trying to connect my Tello to the but that doesn’t work, in the image below is the result of when I connect it to the localhost, but the information about the height or time does not appear, or the angles as it is in the course if someone could help me

thank you very much


my operating system is windows and mi python version is 3.7.4, like the course

Are you connected to Tello’s network directly from your computer that is running Python? Also, are you using Tello or Tello EDU? Let us know and we should be able to get to the bottom of this.

yes i am connected direclty from my pc, yes python is running, i’m using tello, but not at the same time to my computer

I just pulled the code on my PC, installed the Python dependencies, and was able to get it to work:

I wonder if there may be a versioning issue going on with the dependencies. What do you get when you run pip install from the directory of the project? Mine looks like this:

BTW have you updated your Tello firmware from within the Tello app? That’s another thing that sometimes catches us off guard.

what version of python did you use? i’m using python 3.7.4, my tello has updated the firmware,

I already solved it, it was a problem in the network, by default the connection network to the tello was public, I changed it to private and it was solved

thank you very much

Nice work. I haven’t seen this before but very good to know.