Tello Drone Issues

Our Tello drones are now on their 3rd year of use. And sadly, a few are starting to show their age. Has anyone else encountered the following issues and, if so, have you found a solution?

  • The drone won’t stay elevated. It keeps sinking till it lands, but the motors usually keep spinning. It’s either like the motors themselves no longer have the oomph, or like it can’t tell where the ground is anymore. [I have this issue with two of my drones.]

  • The drone won’t respond to commands, even though you can link to its wifi and you get a green light to say it’s connected. When tried with the Tello app on my phone, I get the error message: “Warning: Non-official battery.” Clicking on it gives the message “Restart the aircraft. Contact Ryze Tech Support if the problem persists after restarting.” The battery isn’t the issue - it works fine in other drones. [I have this issue with one drone.]

Has anyone here tried contacting Ryze tech support? Do they tend to respond to emails?

Hi Trina, have you checked the firmware version of this Tello drone vs the others? If so, can you post the firmware version here and I’ll compare to ours? I do know Ryze support will respond…it’s just a matter of when. I’m not sure how much they’ll be able to do given the age of the drone, but it’s certainly worth a shot.

Have you tried calibrating the drones? Many problems like this have been solved by calibrating the drones.

Actually, I think I did do that. But I don’t remember what the process was called. Could you direct me to a website to shows how to calibrate, or describe it here?