Tello Drone LED doesn't cycle and freezes after Takeoff

I am having trouble with two of my Tello drones.
Tello 1: When the drone is powered with a fresh charged battery, the drone’s LED cycles between Green and Red and freezes at Red. It does not connect to droneblocks or any devices. In addition during the firmware update, it didn’t update past 99%. We tried restarting and reconnecting but the drone doesn’t respond and the LED remains at a solid red.

Tello 2: This drone has the updated firmware and connects to droneblocks, however the drone doesn’t respond to code after takeoff. The drone takes off and just hovers endlessly. It only lands when ABORT MISSION is pressed. We tried variations of codes but it seems like the drone freezes and doesn’t respond to the second line of code.

For Tello #1 is it still broadcasting a wifi network that you can connect to?

Regarding Tello #2 we’ve seen this when firmware is out of date or the flying environment isn’t ideal (reflective surface without any patterns that Tello can “see” or not enough lighting). Also, what version of DroneBlocks are you running?