Advanced Tello Programming - Lesson 3

I am trying to make progress on Lesson 3 of the Advanced Tello Programming modules. When I “Run” the code in the Tello_Setup_Test_Notebook, I am not getting the correct response from Jupyter Notebook. I either get NameError: ‘Tello’ is not defined (see below). Or when I tried on another computer the Tello_Setup_Test_Notebook indicated ModuleNotFoundError: NO module named 'djiTellopy’. Any suggestions?

Scroll down to the README on this page:

dbaldwin/tello-adv-setup: Advanced Tello Programming with Python 3 and OpenCV from Pat Ryan (

Did you follow this step:

To install the DJITelloPy API package, in the terminal window type the following:

pip install

When the pip command completes let us check that the install worked.

In the terminal window type the following:


and then

from djitellopy import Tello

I tried to follow your instructions above on 2 of my computers. I succeed on one and not on the other. So…on the successful computer I took the next step in Lesson 3 and my results are indicated below:

What did I do wrong? How do I proceed.
Thank you for your consideration.