DroneBlocks Desktop for Windows Early Beta

We have been working to bring a desktop version of DroneBlocks to life. Our goal is to support Windows and Mac through this effort. The desktop version supports Tello’s camera with a full screen option. You can also program photo and video blocks.

We’ve also worked hard to simplify the connection process. All you need to do is open the DroneBlocks Desktop app, power up Tello, and connect to Tello’s network. The app should immediately detect the connection, start streaming telemetry and video.

Here is a link to the beta version:


After downloading this file you will need to unzip and then double-click the “DroneBlocks.exe” file. Windows may ask to confirm that you want to run this since it was not downloaded through the Microsoft Store. We promise it’s safe! We will be working on a version for the store in the near future after we get all the bugs sorted out.

Also, this version does not yet support saving missions or programming Tello Talent’s LED matrix. That will be coming soon.

We hope you enjoy and please post any feedback/suggestions here. Thanks!

1 Like

@Janine would you please test and let us know how it goes?

Ran the installation of the beta version and all went well. Students used the basic commands with loops and flips and enjoyed the windows experience. Have had n success with the camera as all camera shots are blank at the moment though they have been saved to a drone blocks folder in pictures. The controls themselves seem to work really well though we have not delved into the maths area for the higher-order manoeuvres. The connection to the drone is immediate with no second connection inside the software needed. The year 8’s were excited. We will test further next week.

Good Job ! Good Job ! Good Job !
Thanks :slight_smile:

Hi Doug!

I wanted to add my experience with the Windows Beta and ask a few questions.

We tested the beta out on Surface Go 3s and it worked decently. I will list a bug report below:

Sometimes opening the exe would cause a javascript error.
Some drones didn't open the camera feed or list the stats across the top but would still accept code.
Some drones seemed to run through the commands very quickly (ie Takeoff would start and then the   
next command would immediately run).
Some commands would be skipped.

I made sure that each drone had updated firmware and was still observing issues. Also, I’m sure it had something to do with the sensors on the actual drones and the Tello SDK but I wanted to be exhaustive.

A couple of feature requests that I would love to see are keyboard control/virtual joysticks and maybe even computer vision for the landing pads.

Really love being able to test out the beta and see the camera feed again. I definitely prefer this over the Chrome extension.

Thanks for the feedback. I’m encouraged to hear it runs on the Surface Go 3s. We can work together to resolved some of these other issues. Can you perhaps post a screen shot of the JavaScript error or recall what it says?

We can certainly add a delay between commands if they are executing too quickly. Let us do some more testing, but one thing that comes to mind is how many drones do you have running simultaneously? Sometimes there can be wifi interference that causes commands to be missed.

Thanks Doug!

We are running about 10 at a time usually which definitely could be causing the issue. We try to space students out as much as possible. I can have our people out in the field do some more testing and get you a screenshot as soon as it pops up again.

That definitely sounds like it could be a problem. Especially with all the video streaming going on. Here is what I’d like to propose… we are working on a version that will allow users to toggle the videos stream on and off. Then you can run a test with all of the drones and their cameras off to see if that helps the problem.You can see a beta version with the toggle button:

I’ll post an update later when the team has something for you to test. Thanks for the feedback.

Here is an updated build that allows you to toggle the video stream off/on. Please give this some testing and let us know if you see improved results regarding commands being ignored. Thanks in advance and have a good weekend.