Drones are skipping blocks in missions

My class has previously used the DroneBlocks Chrome extension which, unfortunately, is no more. We downloaded the DroneBlocks app from the Microsoft Store and are now having issues we never experienced with the Chrome extension. We started out with a simple mission (flying in a triangle) to get everyone familiar with the basics of the app. The codes were simple as we have not messed with variables or loops yet, so simply:

Takeoff, fly forward X, yaw right 120, fly forward X, yaw right 120, fly forward X, yaw right 120, land.

We fly over a gridded tarp to ensure the floor is not casting up any shadows, exactly as we’ve done previously with no issues. However, with the new Windows app, out of an entire class, one student’s drone flew the mission as it should. Other students were having a multitude of different issues, such as:

  • taking off and not running the mission, then landing
  • skipping over the fly forward blocks, yawing, then flying forward halfway through the code
  • instead of landing the drone would lower itself, then just hover over the ground indefinitely

Interestingly enough, when we tried simply restarting the mission and flying the exact same one again, we would get different results. This is the third trimester we have used DroneBlocks and have never had these issues, especially not with such simple missions. Are there issues with the Windows app or is there some new step that needs to be taken that was not needed with the Chrome extension?

We use Ryze Tello drones.

Thank you for any and all help!

Ah, I came on here to see if anyone else is having issues with the Windows version of the program. And I’ve experienced the same as you have. I had a simple takeoff, yaw 90, land program. And it would take off and just stay there. The software would say the mission was complete, and yet the drone was still hovering. I had to launch/abort multiple times before it landed.

One thing I noticed was that I get a green light on the Drone when I connect to its Wifi, and yet the software still says there’s no connection. There isn’t a “connect to tello” button in this version as their is in the Chromebook version, so I wonder if the drone wasn’t fully connected.

Meanwhile, the Chromebook version is working fine. (I switched to teaching Drones my second semester this year, so we’ve just started the course.) Sadly, my drones are getting old and I’m still having issues with some of them. (Guess I should be glad I only have 5 students enrolled this semester.)

Hi @nrichhart we’ve been hearing reports of the behavior described but cannot seem to track it down. During all of our testing we are able to successfully execute missions dozens of times with no issue. We’d love to take the opportunity in this thread to track it down. One thing we’ll likely do is introduce a debug mode in the next version of the Desktop app. This will allow us to see what Tello is responding with, which should help us further diagnose. Please make sure you are using DroneBlocks Desktop 0.1.17. You can download the latest here:

https://droneblocks.io/app

Also, perhaps there’s a firewall issue at play. We’ll continue to diagnose but let’s start with making sure you’re on the latest version. Thank you.

@nrichhart @trinalin if you get a chance I’d love to hear if this helps at all with your issues:

I’d also be interested in knowing if you even have access to manage the firewall on your computers. It may something we may need to deal with at the district level, but please let us know.

Good morning, Dennis.

We did not have class yesterday due to weather so I have not had a chance to try the changes you suggested. We are in session today, so I will keep you posted on how things go. As far as firewall protections, I do not have access to that. However, if that becomes something we think is an issue I may be able to get some leeway from our tech department to experiment.

I’ll be in touch,

Nolan

~WRD0000.jpg

Thanks, Nolan. We also have details on specific firewall rules that can be applied if your IT dept doesn’t want to allow all ports for DroneBlocks. Keep us posted and we’re happy to help work through this.

Will do. If we have issues today I’m hoping to get some video footage to send you. I’ll also get screenshots of the code in-case I’m forgetting something stupid and teaching the kids wrongly.

~WRD0000.jpg

Hi, Dennis.

Here is some footage from today. Pardon the background noise, it’s tough to get good video without people talking in the background. The quiet ones are after I got on some people’s cases hahaha. I tried to get footage of the code while the flight is going on, but that’s easier said than done.

https://photos.app.goo.gl/XQhHe4VnuXiucREJ6

This video shows the drone skipping the first step. Although it looks like there is a glare on the grid, I think that’s the angle. The drone completed the rest of the steps after skipping the first one for some reason. We flew the same mission, same drone, several times and got different results almost every time.

https://photos.app.goo.gl/3sdb4Au5QCRDnYKn9

In this video the drone is again skipping steps. This time it skips a yaw 120 and then continues next into the fly forward step. Later in the mission it acknowledges the yaw and does the rest of the mission.

~WRD0000.jpg

Part II of my previous email. The email would not let me include more than two links. Continued below:

https://photos.app.goo.gl/ALboRJjk4BxU3a1Q9

In this video the drone again skips steps. It skips the first fly forward, then skips yaw commands before flying forward, then skipping over another yaw and fly forward command to finish the mission.

Lastly, we also had a couple instances where the drone would be told to abort but would not. Instead it would just lower a bit, then hover indefinitely. When we clicked launch, then abort again, the drone would land as instructed.

We did toggle the camera off and made sure it was not streaming video. Last trimester when we ran the course we were landing almost exactly where we took off from. This trimester we have been lucky to get within 2 square feet of takeoff when flying. Each time we run the exact same mission with the same drone and computer, we have been getting back varying results with no consistency.

~WRD0000.jpg

Okay this is definitely a firewall issue. The fact that you aren’t seeing any telemetry at the top (battery, roll, pitch, yaw, etc) is causing some of the behavior you’re describing.

Can you check my video above and possibly share it with your tech guys?

Which video are you referring to? I do not see a video.

Further up in the thread. This one:

Thanks, Dennis. Sorry about not seeing the link. I’ve just been using our emails as opposed to the thread. I went in and watched the video and sent it off to our Tech Department as well. I definitely did not also check the “public” box. We are out of school today due to weather, so I will give that a try the next time I am at work. Will that box show up each time I open the app or will I need to reinstall it to get the chance to check the different network boxes again? Hopefully that’s the issue. If it is, easy fix!

Thankfully it’s a one-time deal. Whatever you select will be remembered. Obviously if you did not allow firewall access you’ll need to go through the steps in the video. But you should not have to do that again. Let me know if you find out otherwise or if your Tech dept has any concerns.

Dennis,

I was finally able to try the suggestions you had about the firewall issues. On my Tello it seemed to fix the problems. Because of crazy weather last week, I did not have a chance to try this with any of the kid’s drones. I’m hoping to try it tomorrow with a kid or two’s drones just to be sure. I’ll keep you posted.

Thank you again for all of the help!

Nolan

Nolan, thanks for circling back with us! To clarify, where you able to make these changes yourself or did you have to get your tech dept involved? Just thinking ahead as our users transition to the desktop app.

On my machine I was able to make the changes, but I have not been able to try it on student machines yet. I will let you know after I am able to try it either today or tomorrow. Hopefully this fixes our issues. I also was able to fly with the streaming camera during the mission and had no issues. Granted, this may change when there are more than one drone flying at the same time.