Erratic flying after Drone Blocks mission started

I have a classroom set of the Tellos and when my students tried to execute their code the drones just flew away? They did not execute the code properly?
The block code was Takeoff-Flyup 20"-Land, very simple.
The drones ALL flew up then flew right or left and bounced off the wall??

I believe you may be dealing with some environmental factors if you are seeing such erratic behavior. Take a look at this free course that talks about some things you should look at for as it relates to flying Tello programmatically with DroneBlocks:

Troubleshooting Tello | DroneBlocks Curriculum

Please let us know if you have any other questions or concerns!

Thanks Dennis, I am laying non reflective mats down for tomorrow’s class in the hope that works. I tested a few flights with darker surfaces, and it seems to work. I dug out a few exercise mats that connect together, hope they work, they are actually VEX Robotics field mats.

Another question, I purchased the Drone Blocks course for my class, how do I allow students to access that content? Can I share it? Or do you just display and they can mimic on their Drone Blocks software?

Good question. Our curriculum is generally a resource for the educator to share with their students. Students can log into the app and simulator to save/retrieve their mission. I’m not sure if you’ve seen the new DroneBlocks coding simulator but you can find it here:

How did your test flights go?

It went well, I laid down mats that seem to have worked. The Tello does stop responding and just hovers? A couple times there was no abort button available.
Overall, a really fun coupe days.

Can you remind me what system you’re running DroneBlocks on? We’d like to look into the issue with the Abort button not showing up in your drone mission. That’s strange!

Windows and google chrome.