Drones Flying Erratically using Drone Blocks

I have updated the Firmware on our Tello drones and am testing them out with simple code using Drone Blocks. A simple takeoff, hover 5 seconds and land sent the drone up to the ceiling until it hit the ceiling and crashed down to the floor. Another example was flying in a square which started out okay and then flew up high, to the left until it crashed into a wall and fell. A third also flew up to the ceiling and crashed with a simple takeoff and land. We are using a Chromebook to run the Drone Blocks app. This happened with three different Tello drones.

That’s definitely strange behavior. I’m wondering if you can share the same mission with me and I’ll run a test today. If you go to the “My Missions” page there is a share icon next to each mission you’ve saved. Please copy that link and paste it here. It doesn’t sound like an issue with your code, but worth a test. If your drone code is not the problem then perhaps it’s something related to the environment you’re flying in.

Good morning Dennis,

Thank you for the quick response. I tried flying three different drones in two environments. I tried in my classroom yesterday afternoon and then at home last night. Both locations have a rug on the floor. At school it is a gray blue rug and at home a red with multiple colors. I read in the forum that having a light floor may be a problem, but that is not the case.

I did not save the missions, but I can recreate them.

I believe the problem is the latest Firmware Update. I flew the drone at home on Saturday before running any updates and it worked perfectly fine, no issues.

Is it possible that the latest Firmware Update is the problem? Are you able to test that?

Thank you.


We can certainly test but can you confirm the version number of the firmware so we’re on the same page? Thanks for the detailed info.

This is the link for the mission I just saved.


Regarding the Firmware before I made any updates, the firmware version says Next to that it says Update. When I click on Update there’s a version v02.05.01.17 from 5/18/21.

How do I see which version number of the firmware I currently have? I assume I have the one above and before the Firmware Update it was Before yesterday’s Firmware Update, the last time I used the drones was March 2020 before we went remote and they flew fine. As I mentioned, I flew one of them on Saturday before the update and it flew fine.

BTW I forgot to ask are you using DroneBlocks with Tello, Tello EDU, or Tello Talent? I ran your mission last night with Tello EDU and it worked fine. This was the previous firmware version:

and then I updated to Tello EDU firmware version:

Your mission ran fine on both firmware versions.

Hi Dennis, These are the screenshots that I have. My drones say Tello on them. They are either Tello or Tello EDU, but not Talent. Each time I hit the Firmware Update it says, “Latest Firmware”.

Let me check the firmware version of one of our standard Tello drones and get back to you.

Hi Dennis, after replacing all of the batteries with new ones and running an IMU calibration on all six drones, four of them work as expected. Two drones are erratic behavior, each doing something different. I have also confirmed that I have Tello drones (not EDU) and have the latest Firmware updated. I just ran an IMU calibration for a second time on the two “bad” drones. I started will a fully charged battery. My code was simple in DroneBlocks, Takeoff and Land, that was it. I am running the app on an iPad with the latest version of DroneBlocks. One of the Tello drones lifted about four inches off the floor and then fell over to the right. It did that twice. The other drone flew up about 6 feet flying to the right until it hit the wall even though I was hitting the Abort Mission command. Any suggestions? Thank you.

Regina, how comfortable are you with going through the Packet Sender instructions in the following video:

Lesson 3: Sending and Receiving UDP Packets | DroneBlocks Curriculum

I only ask because at this point I’m fairly certain the issues may be hardware or environment related. I don’t think the erratic behavior is because of DroneBlocks. Using Packet Sender would allow you to send commands to your Tello drones and observe their behavior outside of DroneBlocks. This would at the very least help us validate there is not an issue with the DroneBlocks App. Let me know what you think.

I’m trying to come up with some other ideas like propeller mounting or possibly something obstructing Tello’s sensors. But I don’t have any other good ideas at this point in time.

Hi Doug,
I looked at that video and need to back up to the two prior. It’s not something I have tried before but can see if I can follow along. Is it possible to send back the two drones that are erratic and have you take a look at them?

Regina, are you asking if it’s possible to revert your Tello firmware to a previous version? Just want to make sure I understand what you’re asking when you say “back up to the two prior”. Regarding sending the drones back I’ll need to talk to the fulfillment team to see if this is a possibility.

Hi Doug,
Sorry, I wasn’t clear. I meant back up to the two prior videos and lessons as when I started with lesson 3 that you sent, I don’t have the background knowledge to start there. Is anyone available for a call or zoom to help me try your suggestion? We were able to code 4 drones today. We tried the two that were erratic two weeks ago and had the same problem.

Have you looked through this thread that talks about Tello and Packet Sender in detail?

Let me know. Happy to walk you through it if necessary.

1 Like

I am going to need help with this. I watched the video but there is so much background knowledge that I don’t have with this. I have only used the DroneBlocks drag and drop blocks for coding a couple of times. I would like to set up a time for a zoom.
Thank you.