Is there a GO1 Curriculum?

Is there any curriculum that has been published yet for the GO1 (or something that someone has created)? I’d like to have my students work with some prewritten lessons. I’m looking for walkthroughs that may be done with DroneBlocks App, or JavaScript and Python coding. Thanks!

1 Like

Hi @mregannt,

Yes, all of the available Unitree Go1 EDU quadruped curriculum is encompassed within the DroneBlocks Enterprise License. You can view all of the available content on our platform here.

If you have any questions, please feel free to shoot us an email at ( ).


In case you didn’t see it, we announced a course based on Go1 and OpenCV (Python) for some cool examples. There are a couple of preview lessons at the link below:

If there’s anything else you’d like to see related to Go1 content please let us know.

Woohoo! This is right up our alley! Thanks for pointing that out. We’ll get on it next week.

Please let us know how it goes. We are starting development of a new Go1 course that digs a little deeper into programming.

I ran into some issues with the terminal freezing up when we tried connecting to the Go1 Pi. Any ideas?

If it doesn’t freeze up immediately try running:




and it should list the services and resources consumed by each. Either your Pi resources are overloading the system or perhaps there’s a network connection issue at play. Would you mind opening a new thread and we can work through it there?

Ok a few notes so far. The bash script for sending the code to the head is set to /home/unitree but is not capitalized and so drops it in the home. So, that file will need changed to point to the DroneBlocks folder we are told to create. We did manage to copy and with a great deal of trepidation used the recursive remove after copying the folder to the correct directory.

Also the requirements.txt is missing from the zip folder. We can recreate if someone can post the contents here.

Thanks for the feedback. Any chance you can start a new thread? I helped review/test all of Gabe’s code and don’t remember running into any of these issues. If you can post what lesson you’re referring to I can go through it asap and make any updates if necessary. I don’t remember needing any pip requirements given Go1’s Jetson Nano’s should already have the dependencies installed.

I didn’t have a chance to ping the address of the Go1 Pi. I will try to do that on Monday.

1 Like