Cant connect to GO1 edu via wifi on windows


I have been trying to connect to my GO1 edu via wifi on my windows PC, and it does not work. It almost immediately displays “unable to connect to this network” after I type the password in the windows wifi connection tab. I have tried setting it both as a private and a public network, disabling the firewall, to no avail. When I try on linux or my android phone, it works as intended.
Could there be any driver I am missing ? Ethernet does not work either, be it on linux or windows.
I was trying to follow along this tutorial, which does not encounter any problems (and does not need to type a password to connect to go1’s wifi).

This definitely sounds like a possible Firewall issue. I can’t imagine it’s driver related but I’m not a Windows expert. I believe it’s the Raspberry Pi in the Go1 that is broadcasting as an access point. Have you tried connecting from another PC to see if you can replicate the issue?

After further testing, I pinpointed it to a certain wifi chip:

qualcomm atheros qca61x4a

All drivers are up to date, everything works normally when connecting to a standard wifi or ethernet, the problem only shows up with the GO1. The same computer can connect to GO1 when using usb-C ethernet adapter, or a usb wifi module. So maybe a driver bug, on the qualcomm or on the go1’s hotspot.