Windows App Help

Kia ora all,

I’ve just attemted to use the new Droneblocks Windows app on my Windows 11 classroom laptops. It seems that the drone will not connect correctly inside the Droneblocks app.

When you connect to the Tello wifi, the wifi button in the app stays red (no wifi), even though some events like ‘take off’ etc still work, there is no camera access and many of the blocks dont work properly.

Does the Win app support Windows 11?
Am I missing something in regards to setup - I’ve updated firmware/reset the Tellos/fresh batteries etc.

Hi Ryan, we have many users programming their drones with DroneBlocks on Win 11. I definitely sounds like a firewall issue. Can you take a look at this video and give it a try? Let us know how it goes.

Hi again,

I’ve tried the suggestions in the video. Droneblocks has full firewall access but still doesnt work? When I connect to a Tello drones Wifi, it seems to breify connect in the app (battery/telemetry data appears) then it disconnects. Any other suggestions? We manage our school devices with Intune, but there appears to be no clashes on the firewall side of things?

I’ve also tested turning the firewall on/off with no luck. The app appears to completly crash some laptops wifi after briefly connecting to the drop, then dropping out - so the device is unable to connect to any network after the connection in the app fails. This is until we restart the laptops/reset the network adapter?

Also, in the developers console, I get the following errors on opening the app.
Screenshot 2023-02-12 184027

We’ll need to look into this some more. It’s strange that the app could be crashing wifi connections. This sounds like a potential hardware issue but it’s hard to say. We are not altering the connection in any way, just trying to send UDP packets to the drone over a certain port. We are also reading telemetry and video over different ports. Let me ping @ryan to see if he has any ideas. Also, I know @ClintonEvans runs Windows 11 and said he’d be willing assist.

The screenshot you posted are warnings and will not have an effect on the app. It’s something we use for development purposes that we need to remove from our production releases. You can safely ignore those messages for now.

Hopefully we can get you up and running this week.

Thanks, I think we may have found our culprit…

After testing on multiple school devices, we’ve found that any Windows devices managed by Intune MDM will not allow the laptop to connect to the drones network. Looking through our device management poilcys in Intune, there’s nothing (obvious) hindering connections, so we’ve reached out to Microsoft for some support.

We tested the app on a few Macbooks and HP Probooks not enrolled into Intune and both connected fine. This might be something else schools need to look out for…

Fingers crossed Microsoft support can help us identify what the issue is.

Interesting. Please keep us posted as we certainly want to get ahead of this. @ryan check out the post above regarding MDM.

Hi again,

We’ve had some IT contractors look at the issue this week. A few things popped up that will impact schools using MDMs like intune. This is what we’ve learnt so far…

  • Microsoft Defender for Endpoint was blocking the application (due to being an open network?)
  • Our student devices are set up so students sign in with user accounts, which dont have admin rights. The app is pushed through Intune to follow the user, not the device.

Still unsure why on some new staff laptops, the radio/wifi completly crashes after the drone connects to the wifi? Will continue to do some detective work🤞

Thanks for staying on top of this. It’s never as easy as we’d like to think. Especially when dealing with district IT. Unfortunately we do need to have network level access, but perhaps we could help provide rules for only the ports necessary to communicate with Tello.

Hi team, apologies for late reply, been under the weather.
In NZ we have Network For Learning that controls the external firewall. A lot of schools also use Intune to deploy policies and rules. There are a few things we can try here to get a boilerplate solution for this sort of thing.

The Network For Learning techs know me and I’m sure we can get to the bottom of this. Plus I know a few people at Microsoft we can chat to. Let me know your thoughts Ryan. Happy to assist where I can. =)

That would be great Clint!

The N4L side of things is no issue, as the app works on any device not Intune managed.

We’ve had a small improvement with some defender adjustments in Intune. The app will work on some devices, but without camera function. I’m guessing the FFMPEG is still blocked?

We did wonder it could be an account issue/how the devices were set up…Our students sign into devices with Microsoft accounts. Although the app won’t function fully even signing in to a device with the Admin account that enrolled the devices?

If you could provide a set of recommend Intune configurations that get the app working fully, that would be amazing!

Exciting times. Looking forward to solving this issue. :smiley:
Couple questions, as to avoid stepping on the toes of your current IT provider:

  1. Do you have access to LOCAL admin accounts?
  2. Do you have a contractor provider like Aiscorp. Norcomm, Cyclone etc…?

Let’s pretend I rang you for the first time, these would be the initial questions I would ask:

  1. Does the app work fine on the same hardware with a different Win11 config? ie: Teacher devices same model vs student device same model?
  2. Is it all students devices or just some?
  3. Are these student devices all in one group in your Intune? ie Student-Devices.
  4. Do you have access to your Microsoft Entra admin center as a global administrator?

After these are answered we can start the ball rolling to get some results. I’m also more than happy to chat on the phone and do some Teamviewer support to check all the application log files required to really get down to the bottom of this. :slight_smile:
Many thanks

Awesome - Cheers Clint, appreciate this!

Yip - I have access to the Admin account. This is not a local account however. All school devices are setup/enrolled with online accounts.

We have a local ‘one man’ IT company that manages our school netork - He’s stumped, so any help would be great. We also had an external IT contractor to look at the issue who thought it was to do with Defender (and as a result, made some changes to a few settings).

  1. We have tested the app on Win 10, Win 11 and Mac OS devices not enrolled in Intune - all worked perfectly. For Windows, this testing was on Microsoft Surface Go 2’s, and older HP Probook 11 G2s. Our STEM lab has 25 x HP Probook 430 G6, running Win 11, and staff devices are HP Probook 440 G9 (also running Win 11). The wifi crashing is only happening on the staff HP Probook 440s, so that could be something else. But none of these Intune managed laptops will run the app fully.

  2. For now, with the change of settings, we’ve had some success getting the app to work on most student devices we’ve tested, although with limited functionalty (no camera / some code instructions failing). It will not work at all on the staff devices.

  3. The STEM lab student devices are in one group in Intune. As are our staff devices. We have different configuation profies for different groups of devices within Intune. The app will not work fully on any of them.

  4. I’m part of the IT team here, so I have access to all of our Microsoft MDM / 365 as admin.

Hi Ryan,
How are you placed tomorrow afternoon / Friday for a remote support call?
Do you know if your site has Teamviewer access? If not, I can call N4L and get them to open the firewall rule etc…

I can remote in to your most troublesome machine and start collecting data / finding out what’s blocking the ffmpeg.exe etc… plus the wireless adapter dropping off issue. :slight_smile:
Many thanks

Hi Clinton,

Friday Arvo would be great - I’m free from 12.20pm - 3pm NZT. Dont currently have Teamviewer, but can install it on my Staff device? Can i email you off Forum to sort this?

Did you find a resolution to this problem? We are having similar issues…drones seem to connect to the students device but drop out.


Yeah it was all to do with Firewall issues and administrator rights, which is a challenge when using student devices. This was compounded with some of our Intune management policies.

The Droneblocks and the ffmpeg app need full firewall access otherwise things wont work. We had to loosen our security settings in Intune, then give them firewall access.

Hi, Antonio Leoni by win11, droneblocks app, tello edu, and I online have modified firewall defender

Droneblocks app runs correctly if defender open data of droneblocks

Hello I have a lab of Windows 10 laptops, AD joined with students signing in with accounts that do not have admin rights. I have added firewall rules for both ffmpeg and droneblocks to the firewall. When signing in to these device with an admin account, everything works fine. If I sign in with a student account I receive the below message.

Droneblocks app will still load, the connection symbol will show green, but I will not get a video feed and no commands are executed by the drone. Any help appreciated.