DroneBlocks Desktop Beta 0.1.8 for PC and Mac

Thanks to the many testers for providing feedback on the desktop app we now have a more stable version. DroneBlocks Desktop 0.1.8 has the following fixes:

  • Fix for negative values in XYZ blocks
  • Fix to reset Abort button after landing
  • Fix so that Functions are now working again
  • Offline storage for saving missions

Links are below:



Unfortunately, when I tried the windows installation it shows an error saying. “Cannot GET /blockly.html”

Not able to download Windows version either.

@aloh terribly sorry about that. We pushed a bad build. It’s been updated and you should be able to download at the link in the original post.

@korr please try again. New build was just posted.


Just got it. Thank you!

1 Like

Looks like it works. Thanks!

Good morning,

Thank you for the updated. The abort button does reset to the beginning of the program and will take off but will not run the next code after take off. It will start then just land. I am not sure if anyone else is experiencing this behavior

Have a great day

Would you mind posting a screenshot of the mission you’re running? This will allow us to test and try to reproduce the issue. Thanks for reporting!

Do you know yet what the system requirements (hardware, software versions) will be for the PC and Mac apps?

Great question. As of right now Windows 10 and Mac 10.13+ but not certain about specific hardware requirements. We are working to optimize the video feed which does take a fair amount of processing. Are there any specific systems you’re trying to target?

Nothing specific, but we work with schools using this program and we want them to know the exact requirements as to not be surprised by older computers not working. Windows 10 should be fine.

Hi DroneBlocks dev team. Thank you for re-uploading a working build of v0.1.8 so quickly. The exe now works. However, all previously saved missions created with v0.1.6 are no longer present in v0.1.8. They are still retrievable in v.0.1.6. The My Missions portion in v0.1.8 is completely blank. Has anyone else experienced this?

Hello development team! I have a problem with entering the menu in the Windows version. The menu simply does not open. This was the case in version 0.1.6 and unfortunately remained in version 0.1.8. The menu works in the Mac version. Maybe I’m doing something wrong?

try making the window full screen. that helps with the menu


Thanks @adam for the suggestion. That definitely sounds like @Sergij problem. We need to make this more clear as it would be nice if the menu expanded when it’s collapsed into “hamburger” mode.

1 Like

My district uses Duo Security which needs authentication to occur for Droneblocks Windows version 0.1.8 to run. This Windows version hangs at authentication.
See pictures for the Beta version and the hanging screen.


(Be advised that Duo Security has no issues operating with the Droneblocks app running on our

Thank you so much Adam and Dennis. I made sure the menu works in full screen mode. But it would be nice if the menu worked when folded into a “hamburger”

I would stop the program after it flys forward. Once I launch the program again it won’t fly. It will take off then land.

Also can we have a save as option? The students have too many of the same file saved.

Thank yoi

Just a tiny bug I noticed with the Mac version. If you close the app using the red close button and then try to reopen it from your dock you get the following error messages:

Uncaught Exception:
Error: bind EADDRINUSE
at node:dgram:351:20
at process.processTicksAndRejections (node:internal/process/task_queues:84:21)

Uncaught Exception:
Error: bind EADDRINUSE
at node:dgram:351:20
at process.processTicksAndRejections (node:internal/process/task_queues:84:21)

Uncaught Exception:
Error: listen EADDRINUSE: address already in use
at Server.setupListenHandle [as _listen2] (node:net:1372:16)
at listenInCluster (node:net:1420:12)
at GetAddrInfoReqWrap.doListen [as callback] (node:net:1559:7)
at GetAddrInfoReqWrap.onlookup [as oncomplete] (node:dns:73:8)

I would assume that this has something to do with the port connection not being closed when you close the window but I’m not sure. It works fine on first start up and is easily fixed by completely closing the program and restarting but I know how kids can be and wanted to flag it for y’all.

Great work overall and congrats on the Windows app release!

Thanks for pointing this out. We need to figure out how to terminate the connection when the red X is closed. I’m not 100% sure if we can do this but will look into it. We are working to get a version submitted to the Mac App Store soon and we’ll share when we do.