DroneBlocks doesn't connect to Tello wifi

I can’t connect DroneBlocks to Tello wi-fi using ios (iPads). I can connect in the iPad settings, and the Tello app connects and works fine. When I switch to DroneBlocks, the wi-fi connection is dropped and the drone starts blinking yellow. Switch back to Tello app – connects. Switch back to DroneBlocks – disconnects. I saw similar posts that suggested putting devices in airplane mode and connecting wi-fi manually (didn’t work).

Drones have most current firmware. DroneBlocks app was downloaded within past three months, so I’m assuming their up-to-date.

I’m supposed to start a drone program in two weeks. Any suggestions so I don’t have to cancel the coding portion?

Hi, sorry to hear you’re running into problems. Are you switching between the apps in real time? Meaning is one running in the background and you’re switching to the other? If so, that will certainly be a problem. What you can try is the following:

  1. Close all apps
  2. Power up Tello
  3. Open DroneBlocks
  4. Connect to Tello Wifi

After a second or two you should see telemetry data across the top of the screen as well as the camera stream.

BTW we are working on a version of DroneBlocks where you can manually control Tello. After we get through this troubleshooting I’ll be happy to provide a beta link where you can test. You will be able to manual fly Tello and use block coding all from within DroneBlocks.

I went through several iterations of wi-fi connection & apps…sometimes with only DroneBlocks open, sometimes both, sometimes opening the Tello app after DroneBlocks…DroneBlocks never established a connection even if the iPad showed that the wi-fi was connected to the drone. I never saw telemetry data across the top of the screen, and the drone always blinked yellow when DroneBlocks was the active app.

I also tried to connect with an iPhone instead of an iPad. Same issue - DroneBlocks didn’t establish a connection even though the phone was connected according to the wi-fi settings. However, an Android phone works just fine. All of the Apple products are running ios 15.6. Is there any chance there’s an incompatibility with this new ios?

Do you happen to see the following popup when you try to connect to Tello from DroneBlocks for the first time?

After clicking okay you may have to connect again. It’s an issue introduced in iOS 12 or 13 (can’t remember exactly) but after this you’ll need to tap the TELLO-C53822 (or whatever your SSID is) text to see the following popup:

After tapping connect you should see telemetry and the camera:

I was able to test with iOS 15.6. This should only be necessary the first time around. We are trying to find a way to overcome this issue and perhaps it helps you get connected?

Let us know and thanks!

1 Like

I did see the “connect to devices on the local network” message. On one or two iPads, I clicked “Don’t Allow.” For those iPads, I uninstalled & reinstalled DroneBlocks and they work.

For the iPads that I clicked “OK”, I didn’t try connecting again. I tried that today and they all worked.

Thank you so much for your help! The students will get much more out of our program now that they can code their own missions.

Thanks for confirming and we’re sorry for the hassle. We’ll work to improve this process in the near future. Also, if you would like to beta test our upcoming version that has “Virtual Sticks” to manually control the drone please let me know. I can certainly get you added.

Hey Dennis, can I get access to the iPad version with Virtual Sticks? This might intrigue my class as well.