iOS App Disappearing Code Blocks


I am one of the I.T. guys at a school that is attempting to use the DroneBlocks iOS app with some Tello drones.

I saw a previous thread on this, but I didn’t see any resolution, and thought that I could maybe help you to help us by providing some of the details on what we are seeing.

We are using a set of Jamf-managed 5th Generation Mini iPads.

When the app is installed, we can open into it just fine. We hit through the options and the code blocks appear on the left-hand side as they should. However, when we double-tap the Home button and entirely exit the app, we hit a problem. From then on, whenever the app is opened, the code blocks will never appear. Restarting the iPad makes no difference.

It doesn’t seem to be a network issue, as I have tried loading the app on a couple of our SSIDs and also tethered it to my phone.

I adjusted Jamf config to remove restrictions and even went so far as to take an iPad out of Jamf to see if that was interfering somewhere, but it is not.

A couple of wrinkles: the teacher’s iPad (Jamf-managed 7th Gen iPad) and one of the minis were both still on ios 15.4. And on both of those, we could exit and reopen the app without any issue.

Unfortunately, Apple being Apple, we can no longer roll back the rest of the class iPads from 16.0 to 15.4.

I tried updating one of the iPads to the new 16.2 and that didn’t make any difference beyond the DroneBlocks app now requests access to the Local Network. I granted that access in the hope it was going to be the fix, but, unfortunately, it doesn’t help.

The version of the app is 4.0 across the board.

If there is any more info you would like from us, I am happy to try and provide it.

1 Like

Hi Craig,

Please reach out to, we would be happy to schedule a support call.