Some issues with Droneblocks not executing commands

Hi, I just started using a Tello Drone (I am “training” for using it with students next year) and noticed that sometimes when I try from an iPhone to program the drone, the Mission Abort button does not appear. In those instances the drone just hovers in place, and does not appear to be executing the commands.

I tried using centimeters and got a response to the first command but it seemed to stop there. However, I did notice that I can “take over” with the Tello app, though interestingly the option to land doesn’t seem to work (I can, however, land manually)

I am using the phone in airplane mode, by the way, with WiFi enabled.

I did try connecting from a laptop, using the Droneblocks chrome extension on a Mac, but it didn’t seem to connect even though the Tello network showed up in the Wifi menu. I wasn’t sure if I have to just shut Chrome down and restart it tho.

Anyhow, I wondered if there is some obvious step I am missing.

Hi, have you tried updating the firmware? We have a troubleshooting course that walks through this here:

Give that a shot and then we can take it from there!


The app tells me I have the latest firmware. I have since gotten the drone to obey commands - but recently it started this thing where it gets to the first three or four commands and then stops and hovers, though the abort button works.

I am still curious if there is a way to connect this and use the simulator at least on a PC, or if this is only from mobile devices.

Anyhow more to the immediate point, I had a program that said launch, rise 80cm, forward 1400 cm, yaw right 90, forward 400 cm, yaw 180 and then do the same flight path back to the start.

The drone got through the fly up 80 cm, but that was about it.

I just replaced the battery to see if that is the issue?

Have you seen our Chrome app? That will allow you to connect to you Tello drone from PC:

Ah, I think I understand the problem now with your mission not being fully executed. We need to do a better job of handling min/max input values, but the maximum distance we can command Tello to fly in any direction is 500 cm.

The way you can overcome this is to put your fly_forward block (as an example) in a loop. It won’t be a continuous flight as it will stop for a period before it begins the next loop, but it’s a workaround that should suffice.

Hope this helps and keep us posted on your progress. Thanks.